Четверг, 05 Декабрь 2013 10:15

Бухгалтерская отчетность малых предприятий печать pdf417 не активна

Автор
Оцените материал
(3 голосов)

Бухгалтеру понадобилась печатная форма Бухгалтерской отчетность малых предприятий с двумерным штрихкодом pdf417.

На сайте 1с висит информация  о том что формирование отчетности с двоичным кодом будет только для годовой, ликвидационной отчетности и отчетности при реорганизации.

Но ей надо за квартал (не спрашивайте зачем) :)

Решение простое:

В конфигураторе - находим отчет "РегламентированныйОтчетБухОтчетностьМП", и модуле формы "ВыборПечатнойФормы", в процедуре "ПриОткрытии()" напишите перед строчкой ДоступныеПункты = Новый Массив;
строчку:
НастройкиВФорме.ДоступенПункт1=Истина;

в итоге функция должна выглядеть так:

 

Процедура ПриОткрытии()
    
    // Настройки по умолчанию.
    НастройкиВФорме = Новый Структура;
    НастройкиВФорме.Вставить("АктивныйПункт", 1);
    НастройкиВФорме.Вставить("ДоступенПункт1", Истина);
    НастройкиВФорме.Вставить("ДоступенПункт2", Истина);
    НастройкиВФорме.Вставить("ДоступенПункт3", Истина);
    НастройкиВФорме.Вставить("ВключатьКодыСтрок", Истина);
    
    Если ТипЗнч(ПараметрыПечати) = Тип("Структура") Тогда
        ЗаполнитьЗначенияСвойств(НастройкиВФорме, ПараметрыПечати);
    КонецЕсли;
    
    //////////////////////////////////////////////////////
    НастройкиВФорме.ДоступенПункт1=Истина;
    //////////////////////////////////////////////////////

 
    ДоступныеПункты = Новый Массив;
    Если НастройкиВФорме.ДоступенПункт1 Тогда
        ДоступныеПункты.Добавить(1);
    КонецЕсли;
    Если НастройкиВФорме.ДоступенПункт2 Тогда
        ДоступныеПункты.Добавить(2);
    КонецЕсли;
    Если НастройкиВФорме.ДоступенПункт3 Тогда
        ДоступныеПункты.Добавить(3);
    КонецЕсли;
    
    ИндексДоступногоПункта = ДоступныеПункты.Найти(НастройкиВФорме.АктивныйПункт);
    Если ИндексДоступногоПункта = Неопределено Тогда
        ИндексДоступногоПункта = 0;
    КонецЕсли;
    Переключатель1 = ДоступныеПункты[ИндексДоступногоПункта];
    
    ЭлементыФормы.Переключатель1.Доступность = НастройкиВФорме.ДоступенПункт1;
    ЭлементыФормы.Переключатель2.Доступность = НастройкиВФорме.ДоступенПункт2;
    ЭлементыФормы.Переключатель3.Доступность = НастройкиВФорме.ДоступенПункт3;
    
    ВыводитьКолонкуСКодамиСтрок = НастройкиВФорме.ВключатьКодыСтрок;
    УстановитьДоступностьВключенияКодов();
    
КонецПроцедуры
Прочитано 5077 раз
Комментарии   
0 #2 Kuzevich 13.02.2015 12:51
Цитирую махмут:
Можно просто временно выбрать ликвидацию и печать будет возможна.


Хм... Тоже вариант! Спасибо!
Цитировать
+1 #1 махмут 12.02.2015 06:32
"Таким образом, представлять (выгружать) бухгалтерскую (финансовую) отчетности в налоговый орган необходимо только за год. Исключение составляет бухгалтерская отчетность организаций при реорганизации или ликвидации."

Можно просто временно выбрать ликвидацию и печать будет возможна.
Цитировать
Добавить комментарий