Email: Этот адрес электронной почты защищен от спам-ботов. У вас должен быть включен JavaScript для просмотра.

1С Бухгалтерия 2.0.54.11

Бухгалтер пожаловался на отсутствие возможности напечатать машиночитаемые формы отчетности. Стал разбираться с проблемой (Налоговая декларация на имущество и трансортный налог). Оказалось, что в модуле формы в процедуре СформироватьПодменюПечать есть строчка:

РазрешенаПечатьPDF417 = Ложь;

Похоже что проблемы с этим конкретным релизом, т.к. исправление строки на Истину проблему решило (кнопка стала появляться) но форма не выводилась из-за ошибок.

Помогло обновление до следующего релиза 2.0.55.5, в котором строка уже имела вид РазрешенаПечатьPDF417 = Истина; ну и соответственно все работает.

(4059)
(0)

Бухгалтеру понадобилась печатная форма Бухгалтерской отчетность малых предприятий с двумерным штрихкодом pdf417.

На сайте 1с висит информация  о том что формирование отчетности с двоичным кодом будет только для годовой, ликвидационной отчетности и отчетности при реорганизации.

Но ей надо за квартал (не спрашивайте зачем) :)

Решение простое:

В конфигураторе - находим отчет "РегламентированныйОтчетБухОтчетностьМП", и модуле формы "ВыборПечатнойФормы", в процедуре "ПриОткрытии()" напишите перед строчкой ДоступныеПункты = Новый Массив;
строчку:
НастройкиВФорме.ДоступенПункт1=Истина;

в итоге функция должна выглядеть так:

 

Процедура ПриОткрытии()
    
    // Настройки по умолчанию.
    НастройкиВФорме = Новый Структура;
    НастройкиВФорме.Вставить("АктивныйПункт", 1);
    НастройкиВФорме.Вставить("ДоступенПункт1", Истина);
    НастройкиВФорме.Вставить("ДоступенПункт2", Истина);
    НастройкиВФорме.Вставить("ДоступенПункт3", Истина);
    НастройкиВФорме.Вставить("ВключатьКодыСтрок", Истина);
    
    Если ТипЗнч(ПараметрыПечати) = Тип("Структура") Тогда
        ЗаполнитьЗначенияСвойств(НастройкиВФорме, ПараметрыПечати);
    КонецЕсли;
    
    //////////////////////////////////////////////////////
    НастройкиВФорме.ДоступенПункт1=Истина;
    //////////////////////////////////////////////////////

 
    ДоступныеПункты = Новый Массив;
    Если НастройкиВФорме.ДоступенПункт1 Тогда
        ДоступныеПункты.Добавить(1);
    КонецЕсли;
    Если НастройкиВФорме.ДоступенПункт2 Тогда
        ДоступныеПункты.Добавить(2);
    КонецЕсли;
    Если НастройкиВФорме.ДоступенПункт3 Тогда
        ДоступныеПункты.Добавить(3);
    КонецЕсли;
    
    ИндексДоступногоПункта = ДоступныеПункты.Найти(НастройкиВФорме.АктивныйПункт);
    Если ИндексДоступногоПункта = Неопределено Тогда
        ИндексДоступногоПункта = 0;
    КонецЕсли;
    Переключатель1 = ДоступныеПункты[ИндексДоступногоПункта];
    
    ЭлементыФормы.Переключатель1.Доступность = НастройкиВФорме.ДоступенПункт1;
    ЭлементыФормы.Переключатель2.Доступность = НастройкиВФорме.ДоступенПункт2;
    ЭлементыФормы.Переключатель3.Доступность = НастройкиВФорме.ДоступенПункт3;
    
    ВыводитьКолонкуСКодамиСтрок = НастройкиВФорме.ВключатьКодыСтрок;
    УстановитьДоступностьВключенияКодов();
    
КонецПроцедуры
(4860)
(3)